Quantcast
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Recover simulated trades from TOS

Discussion in 'General Discussion' started by status1, Aug 4, 2017.

  1. status1

    status1 Well-Known Member

    I had TOS open yesterday and I was also watching a video and at some point it suddenly crashed with the Blue screen of death than when it tried to restart it only went to a black screen and than stopped.
    After several attempts to restart and using the restart recovery tool I managed to get back to the windows desktop but when I opened TOS again it crashed again so I was wondering if there is a way to recover the simulated trades without opening TOS ?
     
  2. Tim

    Tim Well-Known Member

    I assume the sims you had in there before the crash have now disappeared? If so, if you had saved the simulation file you could reload it. The only other possibility is to reload a saved workspace if you have done that, or reload the last known good one (tos does save them every time you exit). You would have to find the file, they are in program files > thinkorswim folder named workspace....XML. Copy the latest one, reload thinkorswim, save the copy back into the thinkorswim folder, change its name from the default to something like "Saved.xml", start thinkorswim and go to "application settings" and choose the reloaded workspace. This MAY work.
     
  3. status1

    status1 Well-Known Member

    They did not disappear I just can't get to the analyze tab It's weird I can type in some other stock but as soon as I type SPX in the analyze tab it crashes
    Actually now that I am writing about it I don't think i have to look at SPX I could be on another stock and if I export the simulated trades it should export all of them including the SPX
    I think that may work

    I think I have narrowed down the problem to a failing memory stick
    Yesterday I was trying to run the memory test and it would not move at all from the beginning it was just sitting there at 0% complete So today I took out module 2 out of 2 memory modules and I got the memory test to pass with one module than I put back the second one and about half way through the second pass it found a hardware problem
    So now I am going to try TOS again with just one 4Gb module and hopefully it will not crash this time
     
  4. status1

    status1 Well-Known Member

    Looks like that trick worked
    I don't have to be in SPX on the analyze tab to export all simulated trades

    Also looks like the problem with the crash was caused by the failing memory module because it's all working now
    It was just a weird coincidence that the memory stick would fail at the exact same time with SPX
    I guess it's probably because I got a lot of simulated trades and it takes up a lot of memory and probably trying to access the bad module

    So it's all good now
    I just have to buy another 4Gb memory module now
     
  5. stevegee58

    stevegee58 Well-Known Member

    I've had RAM sticks go bad myself. The symptoms can be very subtle, everything from blue screens to programs just "acting funny".
    I diagnosed the problem by using memtest86+ which is a bootable free USB program. I ran that and sure enough I had bad RAM locations. Replaced the RAM stick and all was well.
     
  6. status1

    status1 Well-Known Member

    I was ready to do that too but for some reason it would not fit on my old 250mb usb stick for some reason I only had 109mb free space after deleting everything and it ran out of space as I was downloading it
    So I went back to the windows memory diagnostic

    This was definitely a strange one
    Normally on a rare occasion when I get a blue screen it would just restart and I keep going but this time it was different
    It would restart and then just stop on the black screen before the windows welcome background comes up and than just sit there So than I press the reset and go through the F8 menu and select something from there It seems that every time I tried something it would fail at a different point sometime it goes to those 4 stars that is part of the windows logo and it failed there at different points and it would just reboot by itself and kept doing that going in circles Than after trying the recover method I got to the desktop and seemed like it was working right up to the point when I got to the analyzer and typed SPX than crashed again

    I have a dual boot with windows 10 on the same hard drive so I tried using that but that just goes into recovery mode so I could not use either one to boot up
    At this point I wasn't sure if it was the hard drive or the memory that was causing this problem so I ran the chkdsk and fixed a few thing which I think it part of the crash but nothing major
    Than I tried the memory test and at the beginning of the test it would just sit there doing nothing with 0% complete
    There was a message there saying that some of the test may seem like it's inactive when it's still working but after about 2 minutes of doing nothing I gave up on it
    Than I figured I better save some of my files while I still can so I save one of the backup files and one of the work spaces as I have another spare pc I could load it on but the simulated trades were not on it I could have recreated the simulated trades from the screenshots I save every day but that would take a while with the many accounts that I track

    Than after a a while of rebooting and recovering it seemed like it could boot to the desktop but I did not feel confident it would stay that way so I opened the pc and took out module 2 just to see what happens with the memory test
    and this time the test went through normally with no problems found
    Than I put back the nodule and it was working normally until about half way through the second pass when I found a hardware problem and let it finish the test
    So I pulled that stick and I and it runs fine with just 4Gb except of course during trading hours when it slows down but it was doing that even with 8Gb so maybe it would run slower now but I don't have time to use it during that time so it makes no difference from that standpoint but it works fine after hours when I use it
     
  7. stevegee58

    stevegee58 Well-Known Member

    USB memory sticks are so cheap now I keep one with various bootable utilities on it like memtest86+ and SystemRescueCd. I hardly use it but it's set up if I need it.
     
  8. status1

    status1 Well-Known Member

    So I got the replacement memory module today and installed it and ran the memory diagnostic which passed without any problems Than I opened windows and wanted to see how much memory I have now
    So it's saying I have 8Gb but only 3.19Gb is usable
    I did not look at this before the crash but I am guessing it was the same before so Even though I had 8Gb I am only using less than 4Gb Maybe that's why I did not notice ant difference in speed when I took out the bad module

    I looked for a solution for this online but so far I did not find a fix for this
    I tried to increase the max memory in msconfig/boot section but anything I set above 3.19Gb it gets reset to 0
    So that's a long term mystery to be solved later

    I tried to do what Tim suggested about the simulated trades but this morning when I opened TOS for the first time I got an unexpected error and all my simulated trades got erased
    Fortunately I did an export of my trades so I can reload them but this unexpected error somehow got saved so every time I open TOS I get this error now So now I have to load a previous version that works and than reload my trades
     
  9. Marcas

    Marcas Well-Known Member

    So, you are saying Windows eats up 4+ Gig?

    My suggestion would be: get flash drive, put linux iso file on it (find details on-line), start up your comp from this drive.
    Depending on which linux distro you choose, you will have about 7+ Gb for your disposal. Install java and TOS and play with it.
    You will not change anything on your Win HD. You can configure Flash Drive that it will store your data. If you like it - go dual boot and beyond.
     
  10. status1

    status1 Well-Known Member

    Yes, and from what I have read this is normal max limit for windows 7 32 bit
    For 64 bit it's 192GB
    So yet another thing to consider next time I need to upgrade
    At the moment it's running ok since I am using it at EOD
    I just have to save more often in case I get these unexpected errors that wipes out all my simulated trades
     
  11. Marcas

    Marcas Well-Known Member

    For what I said you don't have to upgrade your hardware. You will upgrade system by installing more efficient OS.
    There are pros and cons - you have to decide for yourself.
     
  12. status1

    status1 Well-Known Member

    Thanks,
    I tried quite a few linux distros in the past but somehow I could never settle on any one of them
    There is always something lacking or needs something else to set it up that complicates things
    Some software is not compatible for both so you have to get a linux version
    The last one I used was Ubuntu with windows XP dual boot that was about 4-5 years ago
    Like you said there are pros and cons
    At this time it's not worth getting complicated just to get the other 4Gb to be used
    According to TOS the min system requirement is 4GB so that's good enough for now I remember a few years ago when it was only 512MB
    So when they change the system requirements even higher than I will decide what to do

    just out of curiosity is anyone here using linux with TOS ?
    Does that work with Excel and RTD ?
     
  13. Marcas

    Marcas Well-Known Member

    I do use TOS in Linux.

    No, Excel doesn't work with Linux, at least not directly. LibreOffice, equivalent of Excel, does not support RTD to my knowledge - I didn't look into it for a while.
     
  14. status1

    status1 Well-Known Member

    Well that's a problem already because I am using Excel and RTD to track my trades so that's a big reason for me not to use Linux at this time Perhaps if and when Libre Office will start to support RTD I may reconsider using Linux
     

Share This Page