Major Performance Issues with ToS

Discussion in 'General Discussion' started by Stephen, Apr 3, 2015.

  1. Stephen

    Stephen Member

    I have had major performance issues off & on for the last 2 yrs with ThinkorSwim. Issues include super slow platform navigation, crashing and freezing. It also takes 5 minutes or so sometimes for the software to close & exit. The primary problem now is everything seems to be a delayed reaction with the interface..super, super takes several seconds for drop downs to appear or the risk graph to populate. Even typing in orders or anything at all is cumbersome. I got rid of any custom scripts a long time ago. I also do not have any special scans or similar going. That cured things for awhile but the "slow" issue is back with a vengeance. The strange thing to me is things will work fine for a few months and then it all goes to crap....of course, Tech Support claims it has nothing to do with the periodic updates causing the issues. Clearly, I am no tech wizard so I am looking for some trouble shooting strategies if anyone has any ideas.

    A few other possible clues: (1) everything runs fine after mkt hrs so maybe it has something to do with how the platform handles the inbound data flow? (2) as the day progresses the platform gets increasingly slow (3) I have not changed my setup in any way - PC, wired internet connection, complex custom scripted charts or any add'l open windows/charts (4) it doesn't matter if i have 10 other programs running, internet browser with 25 open tabs, ONE open, Excel and Word open or just 1 instance of ToS...the performance is the same...uber-slow (5) running ToS using a very similar workspace runs perfectly fine on my laptop - same internet connection too.

    Specs: Dell Inspiron 3847, Win 7 Home Premium 64-bit, ToS 64-bit version, 8GB RAM, Intel Core i-3-4130, 3.4 GHz, 5 Mbps max internet download speed, ping 47ms, jitter 8ms (i know that is super slow in today's world but it hasn't been an issue in the past with ToS, TradeStation, etc.)

    I've gone through all of the std "solutions" offered up by ToS Support including:
    * Uninstall / Re-install 64-bit version
    * Delete GUI flie and restart platform - things are good for about 10min and then slow as molasses again
    * Increased max perm size to 384 - to allow more video card memory ???
    * Re-set RAM allocation setting to 512-2048 - i've used higher settings but it just eats up the extra available memory with no performance improvement

    Any suggestions would be mucho appreciated!
  2. ACS

    ACS Well-Known Member

  3. Kevin Lee

    Kevin Lee Well-Known Member

    Stephen, I had performance issues sometime ago. TOS tech support asked me to send them a file (forgot which one) from the TOS directory. They did something and sent me back a new file to replace the old one. That solved the problem.
  4. Stephen

    Stephen Member

  5. Stephen

    Stephen Member

    Kevin, thanks for the heads up. I finally got a tech support manager to remote into my system. He made some modification to the ToS directory likely similar to yours but he also highly recommended that I install a dedicated video card.
  6. ACS

    ACS Well-Known Member

    Integrated graphics is a poor setup for any trading computer. I agree you need a graphics card but not a super duper gaming card.
  7. fred sun

    fred sun New Member

    you might try 32 and 512 for min and max settings. Also, TOS uses a lot of memory. Close any charts you do not absolutely need.
  8. Randy Schwartzenburg

    Randy Schwartzenburg Well-Known Member

    Try running TOS without ONE. I worked with Andy and showed him how TOS was running great until I opened ONE and went live. TOS began to crawl. I sent Andy a video of the before and after and they said they felt ONE was ok but could see that opening ONE is what was causing TOS to slow and would try and make the data collection more efficient on the July update. I did notice that the problem was as bad after I downloaded the March update. He also said to change the data update on TOS to 3 sec from real time.
  9. Meteor528

    Meteor528 Member

    Steven, I had a major performance issue with TOS and after discussing it with 2nd level support and they got on my system remotely, they found out that my problem had to do with previous trades/adjustments being imported into the Analyze Tab/Risk Graph. If you make an option trade and then make adjustments for a given underlying (IE. RUT--I Trade the RUT), if you then export your trades/adjustments so that you can then bring them back in to see a Risk Graph that takes into account all of your adjustments, TOS will crawl. As you probably know, TOS doesn't keep track of past adjustments in realtime for a trade. So, although this is a nice feature in TOS to be able to keep a trade current, if you have too many trades/adjustments being imported back in, your system will virtually stop and the CPU usage goes to 80-100%.

    I, like you, had tried everything being suggested here, but now that I don't import trades/adjustments any longer, I don't have the TOS performance issues I had before. Hope this helps.
  10. Stephen

    Stephen Member

    Good to know...many thanks. I do delete any sim trades I am modeling with my live positions on the risk graph...those tend to pile up as well if you don't purge them periodically.
  11. dtheo

    dtheo Member

    I had the same issue - it only takes a few positions in the analyze tab to bog ToS down. Another solution is to blank the symbol field in order to bring up all positions and then uncheck ALL. Watch your CPU in task manager when you do this and it should drop significantly. Then you can check on any you need to work with. saves you from importing/exporting a lot

  12. Randy Schwartzenburg

    Randy Schwartzenburg Well-Known Member

    Andy sent me a beta version of ONE that should fix the performance problems between TOS and ONE. I used it and it seems to fix my issues. If you are interested in testing the beta version contact Andy at ONE.
  13. Boomer34

    Boomer34 Well-Known Member

    I am new to TOS and was wondering what I should set the memory usage to on startup?
    The first number is 32 up to 512. The second number is 768 to 6494.

  14. meyer99

    meyer99 Well-Known Member

    Min in the 3000's
  15. Boomer34

    Boomer34 Well-Known Member

    Thanks for the reply.
    Is there any reason to not put the settings on max? I have a newer laptop and all it will have on it is TOS and either OV or ONE...
  16. garyw

    garyw Well-Known Member

    Here is my current settings. However, Not clear what it really should be.
  17. Boomer34

    Boomer34 Well-Known Member

    While we are on the topic, is there anything I should know on the front end about settings that should be changed or modified to maximize performance? I read earlier about analyzing trades, importing trades, etc...
    Any wisdom would be much appreciated!
  18. status1

    status1 Well-Known Member

    I have the same performance issues as everyone mentioned here although I am using Windows xp with 512 and 1024 setting and it's decent for what I am using it for

    It seems that the more improvements they make the more memory it needs
    Years ago it would work with 512 ram now it needs a lot more just to run at the same speed and not sure what exactly was changed since it does not look all that different but I can't complain too much since it's the only one withe free risk graph which is needed for complex options

    It's pretty much useless if I want to use it in live trading I actually bought a windows 7 pc just so I can use it on a rare occasion that I am at home during live trading otherwise I am using the xp at EOD just to record my p/l and greeks from the price slice for the different accounts

    When I first enter the SPX symbol it 's very sluggish with delayed reaction for about a minute than after that I can click on any of the adjustments and it works fine

    One other observation I made was that if I am on the internet it also slows down TOS to the point that there is a pop up window that shows up saying that tos is having a performance issue
    Yea, thanks like I did not noticed that already
    So I just have to close my browser until I am finished with TOS
  19. Challenger

    Challenger Member

    One of the biggest performance improvements for me was to slow down the TOS quote speed to Maximum delay (15 seconds). This is done by clicking the setup gear in the top right corner then selecting the general tab, then the System menu. I trade the M3 and having real time quotes is not as important to me.

    I also hear users running multiple instances of TOS when they have multiple accounts. I believe this could negatively impact performance. I run only one instance of TOS, but I have linked my accounts on the TDAmeritrade web site so I can see them all in the account drop down list in TOS.

    Last tip - if you are not using the analyze tab for a while, clear the symbol so TOS does not use resources constantly updating the information there.

    My memory settings are: 1024 / 3328
    I run Windows 10 on an Intel I7 CPU and 8GB of ram and the performance is great.
    I am also running TOS 64 bit.

    Hope this helps!
    Last edited: Nov 10, 2016
  20. Meteor528

    Meteor528 Member

    It used to be that if you downloaded TOS from the TDAmeritrade website, you were downloading a 32 bit version of TOS, limiting you to how much of your RAM you could actually use. There was a 64 bit version which was downloadable only from This version performs much better if you have Windows 7 or Window 10 on a newer computer because it allow more options as to how much RAM you can use. I'm not sure if this is still the case, but check it out.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice